package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\d+\s?[^\d\s]+)|(?:[^\d\s]+\s?\d+))$`)
var str = `99 $
99$
$ 99
$99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}