$re = '/^((?:\d+\s?[^\d\s]+)|(?:[^\d\s]+\s?\d+))$/mu';
$str = '99 $
99$
$ 99
$99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);