#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<li style="display: list-item;" class="mc-container"><a href="([^"]+)".*?data-querystring="id=(\d+)".*?<img src="([^"]+)".*?<a[^>]+>([^<]+)</a>"
Local $sString = "<li style="display: list-item;" class="mc-container"><a href="http://youpeliculasweb.com/cantinflas-2014" title="Cantinflas 2014 (2014) PelÃcula Online"><div class="tool mc-item"><div class="info_movie tile" data-tipped="http://youpeliculasweb.com/cantinflas-2014/info" data-querystring="id=4303"><div class="play_go"></div><img src="http://img-youpeliculas.com/images/2014/09/09/Cantinflas2B20142Bonline.jpg" alt="Cantinflas 2014 (2014) PelÃcula Online"></div></div></a><div class="library-show"><h4><div class="title-overflow"></div><a class="title" href="http://youpeliculasweb.com/cantinflas-2014" title="Cantinflas 2014 (2014) PelÃcula Online">Cantinflas 2014</a></h4></div></li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")