# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<li style=\"display: list-item;\" class=\"mc-container\"><a href=\"([^\"]+)\".*?data-querystring=\"id=(\d+)\".*?<img src=\"([^\"]+)\".*?<a[^>]+>([^<]+)</a>"
test_str = "<li style=\"display: list-item;\" class=\"mc-container\"><a href=\"http://youpeliculasweb.com/cantinflas-2014\" title=\"Cantinflas 2014 (2014) PelÃcula Online\"><div class=\"tool mc-item\"><div class=\"info_movie tile\" data-tipped=\"http://youpeliculasweb.com/cantinflas-2014/info\" data-querystring=\"id=4303\"><div class=\"play_go\"></div><img src=\"http://img-youpeliculas.com/images/2014/09/09/Cantinflas2B20142Bonline.jpg\" alt=\"Cantinflas 2014 (2014) PelÃcula Online\"></div></div></a><div class=\"library-show\"><h4><div class=\"title-overflow\"></div><a class=\"title\" href=\"http://youpeliculasweb.com/cantinflas-2014\" title=\"Cantinflas 2014 (2014) PelÃcula Online\">Cantinflas 2014</a></h4></div></li>"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.