package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b[A-Z]\w+\b)(\s+\b[A-Z]\w+\b){2,}`)
var str = `Gaius Julius Caesar`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}