$re = '/(\b[A-Z]\w+\b)(\s+\b[A-Z]\w+\b){2,}/';
$str = 'Gaius Julius Caesar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);