#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+:(?:(?!.*[.!?])(.*))?"
Local $sString = "Choose: blah blah blah 123 for 100'ish characters, this matches" & @CRLF & _
"" & @CRLF & _
"Choose: blah blah blah 123! for 100'ish characters?, .this potential match fails for the ! ? and ."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")