$re = '/^\w+:(?:(?!.*[.!?])(.*))?/m';
$str = 'Choose: blah blah blah 123 for 100\'ish characters, this matches
Choose: blah blah blah 123! for 100\'ish characters?, .this potential match fails for the ! ? and .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);