$re = '/(?:(?<==)|(?=\w+=))(employee_id)\b/m';
$str = '=employee_id
employee_id=
=employee_id=
employee_id
employee_identity=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);