re = /(?:(?<==)|(?=\w+=))(employee_id)\b/m
str = '=employee_id
employee_id=
=employee_id=
employee_id
employee_identity='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end