using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?:solutions\/(?:99043|60009|40117)(?:\/.*)?|search\b.*)?$";
string input = @"/
/solutions/99043
/solutions/99043/blah
/solutions/60009
/solutions/60009/blah
/solutions/40117
/solutions/40117/blah
/search
/search?blah
/abc
/solutions/123
/solutions/
/solutions/60009!
/searchhere
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}