# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\/(?:solutions\/(?:99043|60009|40117)(?:\/.*)?|search\b.*)?$"
test_str = ("/\n\n"
"/solutions/99043\n"
"/solutions/99043/blah\n\n"
"/solutions/60009\n"
"/solutions/60009/blah\n\n"
"/solutions/40117\n"
"/solutions/40117/blah\n\n"
"/search\n"
"/search?blah\n\n\n"
"/abc\n"
"/solutions/123\n"
"/solutions/\n"
"/solutions/60009!\n"
"/searchhere\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.