package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)|(.+?)`)
var str = `This movie is not so good
This movie is good`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}