$re = '/(\S+)|(.+?)/m';
$str = 'This movie is not so good
This movie is good';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);