use strict;
my $str = '{{ param1 | trans }} {% trans %} businesshours.others.until {% endtrans %} {{ param2 | trans }}: {{ business_hours_params.businessHoursParam3 }} – {{ business_hours_params.businessHoursParam4 }} {% trans %} businesshours.posttext {% endtrans %}<br>';
my $regex = qr@{%\strans\s+%}\s(.*?)\s+{%\sendtrans\s%}@ximp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}