re = /{%\strans\s+%}\s(.*?)\s+{%\sendtrans\s%}/xim
str = '{{ param1 | trans }} {% trans %} businesshours.others.until {% endtrans %} {{ param2 | trans }}: {{ business_hours_params.businessHoursParam3 }} – {{ business_hours_params.businessHoursParam4 }} {% trans %} businesshours.posttext {% endtrans %}<br>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end