using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-záéíóúñ]{2,}([\s][A-Za-záéíóúñ]{2,})+$";
string input = @"jose davilá";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}