package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-záéíóúñ]{2,}([\s][A-Za-záéíóúñ]{2,})+$`)
var str = `jose davilá`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}