import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ (?# match the beginning of the string)\n"
+ "(?: (?# start non-capturing group)\n"
+ " (?!\\[) (?# negative lookahead for [)\n"
+ " .+ (?# match 1+ characters)\n"
+ " | (?# OR)\n"
+ " .+ (?# match 1+ characters)\n"
+ " (?<!\\]) (?# negative lookbehind for ])\n"
+ ") (?# end non-capturing group)\n"
+ "$ (?# match the end of the string)";
final String string = "test\n"
+ "[test]\n"
+ "[te]st\n"
+ "te[st]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}