#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^ \h*+ " & @CRLF & _
"(?<VOTERNO> [0-9]+ ) \h+" & @CRLF & _
"(?<SURNAME> \S+ (?>\h\S+)*? ) \h{2,}" & @CRLF & _
"(?<OTHERNAMES> \S+ (?>\h\S+)*? ) \h{2,}" & @CRLF & _
"(?<DOB> [0-9]{2}-[0-9]{2}-[0-9]{4} ) \h+" & @CRLF & _
"(?<SEX> [FM] ) \h+" & @CRLF & _
"(?<APPID_RECNO> [0-9A-Z/]+ ) \h+" & @CRLF & _
"(?<VILLAGE> \S+ (?>\h\S+)* ) " & @CRLF & _
"\h* $"
Local $sString = " NATIONAL VOTERS' REGISTER" & @CRLF & _
" ELECTORAL COMMISSION ACT, CAP(140)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" DISTRICT : 12 JOI" & @CRLF & _
" CONSTITUENCY : 035 GRGR RT" & @CRLF & _
" SUB-COUNTY : 11 GHT" & @CRLF & _
" PARISH : 01 ATZ" & @CRLF & _
" POLLING STATION : 01 OT" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" TOTAL: 398" & @CRLF & _
"" & @CRLF & _
" NO OF PAGES : 9" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" THE REPUBLIC" & @CRLF & _
" NATIONAL VOTERS' REGISTER" & @CRLF & _
" ELECTORAL COMMISSION ACT, CAP(140)" & @CRLF & _
" NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016" & @CRLF & _
" DISTRICT : 12 JOI PARISH : 01 ATZ" & @CRLF & _
" CONSTITUENCY : 035 GRGR RT POLLING STATION : 01 OT" & @CRLF & _
" SUB-COUNTY : 11 GHT" & @CRLF & _
"VOTER NO SURNAME OTHERNAMES DOB SEX APPID/RECEIPT NO VILLAGE" & @CRLF & _
" 57534676 AAA BBB 01-01-1965 M 0323830000V0C/CM5607 ABC" & @CRLF & _
"" & @CRLF & _
" 53276273 CCC DDD 28-07-1981 M 1074620203FUX/CM9007 TTR RR" & @CRLF & _
" TOTAL: 398 PAGE : 1 OF 9" & @CRLF & _
"" & @CRLF & _
" THE REPUBLIC" & @CRLF & _
" NATIONAL VOTERS' REGISTER" & @CRLF & _
" ELECTORAL COMMISSION ACT, CAP(140)" & @CRLF & _
" NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016" & @CRLF & _
" DISTRICT : 12 JOI PARISH : 01 ATZ" & @CRLF & _
" CONSTITUENCY : 035 GRGR RT POLLING STATION : 01 OT" & @CRLF & _
" SUB-COUNTY : 11 GHT" & @CRLF & _
"VOTER NO SURNAME OTHERNAMES DOB SEX APPID/RECEIPT NO VILLAGE" & @CRLF & _
" 53390750 EEE FFF 18-04-1978 F 13238200006Z6/CF8507 TTR" & @CRLF & _
" 60977834 GGG HHH 25-05-1979 F 1176520002RK4/CF1907 BREH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")