# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^ \h*+
(?<VOTERNO> [0-9]+ ) \h+
(?<SURNAME> \S+ (?>\h\S+)*? ) \h{2,}
(?<OTHERNAMES> \S+ (?>\h\S+)*? ) \h{2,}
(?<DOB> [0-9]{2}-[0-9]{2}-[0-9]{4} ) \h+
(?<SEX> [FM] ) \h+
(?<APPID_RECNO> [0-9A-Z/]+ ) \h+
(?<VILLAGE> \S+ (?>\h\S+)* )
\h* $
"""
test_str = (" NATIONAL VOTERS' REGISTER\n"
" ELECTORAL COMMISSION ACT, CAP(140)\n\n\n\n\n"
"NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016\n\n\n\n"
" DISTRICT : 12 JOI\n"
" CONSTITUENCY : 035 GRGR RT\n"
" SUB-COUNTY : 11 GHT\n"
" PARISH : 01 ATZ\n"
" POLLING STATION : 01 OT\n\n\n\n\n"
" TOTAL: 398\n\n"
" NO OF PAGES : 9\n\n\n\n\n"
" THE REPUBLIC\n"
" NATIONAL VOTERS' REGISTER\n"
" ELECTORAL COMMISSION ACT, CAP(140)\n"
" NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016\n"
" DISTRICT : 12 JOI PARISH : 01 ATZ\n"
" CONSTITUENCY : 035 GRGR RT POLLING STATION : 01 OT\n"
" SUB-COUNTY : 11 GHT\n"
"VOTER NO SURNAME OTHERNAMES DOB SEX APPID/RECEIPT NO VILLAGE\n"
" 57534676 AAA BBB 01-01-1965 M 0323830000V0C/CM5607 ABC\n\n"
" 53276273 CCC DDD 28-07-1981 M 1074620203FUX/CM9007 TTR RR\n"
" TOTAL: 398 PAGE : 1 OF 9\n\n"
" THE REPUBLIC\n"
" NATIONAL VOTERS' REGISTER\n"
" ELECTORAL COMMISSION ACT, CAP(140)\n"
" NVR TEXT REGISTER FOR GENERAL ELECTIONS 2015/2016\n"
" DISTRICT : 12 JOI PARISH : 01 ATZ\n"
" CONSTITUENCY : 035 GRGR RT POLLING STATION : 01 OT\n"
" SUB-COUNTY : 11 GHT\n"
"VOTER NO SURNAME OTHERNAMES DOB SEX APPID/RECEIPT NO VILLAGE\n"
" 53390750 EEE FFF 18-04-1978 F 13238200006Z6/CF8507 TTR\n"
" 60977834 GGG HHH 25-05-1979 F 1176520002RK4/CF1907 BREH")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.