$re = '/filename[^;\n=]*=(([\'"]).*?\2|[^;\n]*)/';
$str = 'attachment; filename=content.txt
attachment; filename*=UTF-8\'\'filename.txt
attachment; filename="EURO rates"; filename*=utf-8\'\'%e2%82%ac%20rates
attachment; filename="omáèka.jpg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);