import re
regex = re.compile(r"filename[^;\n=]*=((['\"]).*?\2|[^;\n]*)")
test_str = ("attachment; filename=content.txt\n"
"attachment; filename*=UTF-8''filename.txt\n"
"attachment; filename=\"EURO rates\"; filename*=utf-8''%e2%82%ac%20rates\n"
"attachment; filename=\"omáèka.jpg\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")