#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)filename[^;=\n]*=(?:(\\?['"])(.*?)\1|(?:[^\s]+'.*?')?([^;\n]*))"
Local $sString = "attachment; filename=content.txt" & @CRLF & _
                "attachment; filename*=UTF-8''filename.txt" & @CRLF & _
                "attachment; filename="EURO rates"; filename*=utf-8''%e2%82%ac%20rates" & @CRLF & _
                "attachment; filename=EURO rates; filename*=utf-8''%e2%82%ac%20rates" & @CRLF & _
                "attachment; filename="omáèka.jpg"" & @CRLF & _
                "attachment; filename=\"omáèka.jpg\"" & @CRLF & _
                "attachment; filename*=iso-8859-1'en'%A3%20rates" & @CRLF & _
                "attachment; filename=EXAMPLE- I'm ößä.dat; filename*=iso-8859-1''EXAMPLE-%20I%27m%20%F6%DF%E4.dat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")