const regex = /filename[^;=\n]*=(?:(\\?['"])(.*?)\1|(?:[^\s]+'.*?')?([^;\n]*))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('filename[^;=\\n]*=(?:(\\\\?[\'"])(.*?)\\1|(?:[^\\s]+\'.*?\')?([^;\\n]*))', 'ig')
const str = `attachment; filename=content.txt
attachment; filename*=UTF-8''filename.txt
attachment; filename="EURO rates"; filename*=utf-8''%e2%82%ac%20rates
attachment; filename=EURO rates; filename*=utf-8''%e2%82%ac%20rates
attachment; filename="omáèka.jpg"
attachment; filename=\\"omáèka.jpg\\"
attachment; filename*=iso-8859-1'en'%A3%20rates
attachment; filename=EXAMPLE- I'm ößä.dat; filename*=iso-8859-1''EXAMPLE-%20I%27m%20%F6%DF%E4.dat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}