package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<Name>[^[]*)\[(?P<Values>[^]]*)\]`)
var str = `Name[data1] Name2[data1 data2 data3] Name3[data1 data2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}