re = /(?P<Name>[^[]*)\[(?P<Values>[^]]*)\]/m
str = 'Name[data1] Name2[data1 data2 data3] Name3[data1 data2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end