package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:=|\+)\s*(\d+)`)
var str = `Z = 4x1 + 3x2 + 6x3 // 4 3 6
Z = 24x1 + 33x2 + 68x3 // 24 33 68
Z = 412x1 + 309x2 + 612x3 // 412 309 612
Z = 4329x1 + 3901x2 + 6716x3 // 4329 3901 6716
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}