const regex = /([[:alnum:]|\s|.]*)(?!the)/ui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[:alnum:]|\\s|.]*)(?!the)', 'ui')
const str = `this is completely customizable through the dashboard. This is a separate area from the main c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}