re = /([[:alnum:]|\s|.]*)(?!the)/i
str = 'this is completely customizable through the dashboard. This is a separate area from the main c'
# Print the match result
str.match(re) do |match|
puts match.to_s
end