using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(SS[0-9]{2})(?:\h+-\h+(?1))|(WS[0-9]{2}\/[0-9]{2})(?:\h+-\h+(?2)))$";
string input = @"SS00 - SS99
WS00/00 - WS99/99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}