re = /^(?:(SS[0-9]{2})(?:\h+-\h+(?1))|(WS[0-9]{2}\/[0-9]{2})(?:\h+-\h+(?2)))$/m
str = 'SS00 - SS99
WS00/00 - WS99/99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end