$re = '/^[a-zA-Z]([a-zA-Z0-9.-]{0,8}[a-zA-Z0-9])?$/m';
$str = 'Men-777.99
M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);