$re = '/\[\[[^|]+\|(.+?)]]/m';
$str = 'Some random text about [[Roman Empire|the romans]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);