re = /\[\[[^|]+\|(.+?)]]/m
str = 'Some random text about [[Roman Empire|the romans]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end