$re = '/.*\/watch\/\d+/m';
$str = 'http://www.hulu.jp/watch/589851/supernatural-dub-hollywood-babylon/en';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);