re = /.*\/watch\/\d+/m
str = 'http://www.hulu.jp/watch/589851/supernatural-dub-hollywood-babylon/en'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end