$re = '/^(?!.*(\'\'| |--|- |\' | \.| -|\.\.|\n))[\'a-z][- \'.a-z]*$/i';
$str = 'John Doe K. R.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);