re = /^(?!.*(''| |--|- |' | \.| -|\.\.|\n))['a-z][- '.a-z]*$/i
str = 'John Doe K. R.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end