#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-e]|^[A-E]"
Local $sString = "Cake" & @CRLF & _
"Apple" & @CRLF & _
"Orange" & @CRLF & _
"appricot" & @CRLF & _
"ban" & @CRLF & _
"xerox"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")