package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-e]|^[A-E]`)
var str = `Cake
Apple
Orange
appricot
ban
xerox`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}