$re = '/((.)\2+)((?:(.)\4+)*)((?:(.)\6+))/m';
$str = 'abxxxyyyyzzpqr
xxabcyyyzzpqr
xaaab,,,@@@&&
xxaaab,,,@@@&&
aabb
aabbccc';
$subst = "$5$3$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;