import Foundation
let pattern = #"((.)\2+)((?:(.)\4+)*)((?:(.)\6+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abxxxyyyyzzpqr
xxabcyyyzzpqr
xaaab,,,@@@&&
xxaaab,,,@@@&&
aabb
aabbccc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$5$3$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)