using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ERROR: (?<j>\{(?:[^{}]|(?&j))*\})";
string input = @"ERROR: {""some"": ""info""}
INFO: {""some"": ""info""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}