package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ERROR: (?<j>\{(?:[^{}]|(?&j))*\})`)
var str = `ERROR: {"some": "info"}
INFO: {"some": "info"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}