#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\u0027\u02B9\u02BB\u02BC\u02BE\u02C8\u02EE\u0301\u0313\u0315\u055A\u05F3\u07F4\u07F5\u1FBF\u2018\u2019\u2032\uA78C\uFF07]"
Local $sString = "' - 0027 APOSTROPHE" & @CRLF & _
"ʹ - 02B9 MODIFIER LETTER PRIME" & @CRLF & _
"ʻ - 02BB MODIFIER LETTER TURNED COMMA" & @CRLF & _
"ʼ - 02BC MODIFIER LETTER APOSTROPHE" & @CRLF & _
"ʾ - 02BE MODIFIER LETTER RIGHT HALF RING" & @CRLF & _
"ˈ - 02C8 MODIFIER LETTER VERTICAL LINE" & @CRLF & _
"ˮ - 02EE MODIFIER LETTER DOUBLE APOSTROPHE" & @CRLF & _
"́ - 0301 COMBINING ACUTE ACCENT" & @CRLF & _
"̓ - 0313 COMBINING COMMA ABOVE" & @CRLF & _
"̕ - 0315 COMBINING COMMA ABOVE RIGHT" & @CRLF & _
"՚ - 055A ARMENIAN APOSTROPHE" & @CRLF & _
"׳ - 05F3 HEBREW PUNCTUATION GERESH" & @CRLF & _
"ߴ - 07F4 NKO HIGH TONE APOSTROPHE" & @CRLF & _
"ߵ - 07F5 NKO LOW TONE APOSTROPHE" & @CRLF & _
"᾿ - 1FBF GREEK PSILI" & @CRLF & _
"‘ - 2018 LEFT SINGLE QUOTATION MARK" & @CRLF & _
"’ - 2019 RIGHT SINGLE QUOTATION MARK" & @CRLF & _
"′ - 2032 PRIME" & @CRLF & _
"ꞌ - A78C LATIN SMALL LETTER SALTILLO" & @CRLF & _
"' - FF07 FULLWIDTH APOSTROPHE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")