using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u0027\u02B9\u02BB\u02BC\u02BE\u02C8\u02EE\u0301\u0313\u0315\u055A\u05F3\u07F4\u07F5\u1FBF\u2018\u2019\u2032\uA78C\uFF07]";
string input = @"' - 0027 APOSTROPHE
ʹ - 02B9 MODIFIER LETTER PRIME
ʻ - 02BB MODIFIER LETTER TURNED COMMA
ʼ - 02BC MODIFIER LETTER APOSTROPHE
ʾ - 02BE MODIFIER LETTER RIGHT HALF RING
ˈ - 02C8 MODIFIER LETTER VERTICAL LINE
ˮ - 02EE MODIFIER LETTER DOUBLE APOSTROPHE
́ - 0301 COMBINING ACUTE ACCENT
̓ - 0313 COMBINING COMMA ABOVE
̕ - 0315 COMBINING COMMA ABOVE RIGHT
՚ - 055A ARMENIAN APOSTROPHE
׳ - 05F3 HEBREW PUNCTUATION GERESH
ߴ - 07F4 NKO HIGH TONE APOSTROPHE
ߵ - 07F5 NKO LOW TONE APOSTROPHE
᾿ - 1FBF GREEK PSILI
‘ - 2018 LEFT SINGLE QUOTATION MARK
’ - 2019 RIGHT SINGLE QUOTATION MARK
′ - 2032 PRIME
ꞌ - A78C LATIN SMALL LETTER SALTILLO
' - FF07 FULLWIDTH APOSTROPHE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}