$re = '/\[[^\[\]]*\]\s*[<>|<=|>=|=|>|<]\s*\'?"?\w*\'?"?/';
$str = '[household_roster_relationships_topersona_nameadditionalpersono] = "1" OR [household_roster_relationships_topersona_nameadditionalpersono] >= "1" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);