re = /\[[^\[\]]*\]\s*[<>|<=|>=|=|>|<]\s*'?"?\w*'?"?/
str = '[household_roster_relationships_topersona_nameadditionalpersono] = "1" OR [household_roster_relationships_topersona_nameadditionalpersono] >= "1" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end