using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"20(?=(?:[\da-fA-F]{2})*$)";
string input = @"324F8D8A20561205231920";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}